$re = '/[A-Z]{2,}(?=[A-Z][a-z]|\b)|[A-Z][a-z]*/m';
$str = 'Last First Middle
LAST First Middle
Last FirstMiddle
LAST FirstMiddle
LastFirst Middle
LASTFirst Middle
LastFirstMiddle
LASTFirstMiddle';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);