import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?<tag>[^\\]]+)]\\s*(?<content>[\\w\\W]+?)\\s*\\[\\/\\1]";
final String string = "[SLUG]ghana-cocoa-supply-shortfall-impacts-traders[/SLUG]\n\n"
+ "[TITLE]Sweet Trouble: Ghana's Cocoa Shortfall Leaves Traders in a Bitter Spot[/TITLE]\n\n"
+ "[EXCERPT]Ghana's cocoa bean delivery hiccup has traders facing a whopping $1 billion loss. Here's what happened and why it matters for your morning mocha.[/EXCERPT]\n\n"
+ "[BODY]\n"
+ "<p>Hey there, chocolate lovers and market watchers! Grab your favorite cocoa-based snack because we've got some news that might make your wallet feel a little lighter (but hopefully not your candy bar).</p>\n"
+ "[/BODY]\n\n"
+ "[CATEGORIES]Finance,Commodities,Global Trade[/CATEGORIES]\n\n"
+ "[TAGS]cocoa,Ghana,commodities,trading,supplychain,chocolate[/TAGS]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}