use strict;
my $str = '[SLUG]ghana-cocoa-supply-shortfall-impacts-traders[/SLUG]
[TITLE]Sweet Trouble: Ghana\'s Cocoa Shortfall Leaves Traders in a Bitter Spot[/TITLE]
[EXCERPT]Ghana\'s cocoa bean delivery hiccup has traders facing a whopping $1 billion loss. Here\'s what happened and why it matters for your morning mocha.[/EXCERPT]
[BODY]
<p>Hey there, chocolate lovers and market watchers! Grab your favorite cocoa-based snack because we\'ve got some news that might make your wallet feel a little lighter (but hopefully not your candy bar).</p>
[/BODY]
[CATEGORIES]Finance,Commodities,Global Trade[/CATEGORIES]
[TAGS]cocoa,Ghana,commodities,trading,supplychain,chocolate[/TAGS]';
my $regex = qr/\[(?<tag>[^\]]+)]\s*(?<content>[\w\W]+?)\s*\[\/\1]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}