re = /\[(?<tag>[^\]]+)]\s*(?<content>[\w\W]+?)\s*\[\/\1]/
str = '[SLUG]ghana-cocoa-supply-shortfall-impacts-traders[/SLUG]
[TITLE]Sweet Trouble: Ghana\'s Cocoa Shortfall Leaves Traders in a Bitter Spot[/TITLE]
[EXCERPT]Ghana\'s cocoa bean delivery hiccup has traders facing a whopping $1 billion loss. Here\'s what happened and why it matters for your morning mocha.[/EXCERPT]
[BODY]
<p>Hey there, chocolate lovers and market watchers! Grab your favorite cocoa-based snack because we\'ve got some news that might make your wallet feel a little lighter (but hopefully not your candy bar).</p>
[/BODY]
[CATEGORIES]Finance,Commodities,Global Trade[/CATEGORIES]
[TAGS]cocoa,Ghana,commodities,trading,supplychain,chocolate[/TAGS]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end