const regex = /\[(?<tag>[^\]]+)]\s*(?<content>[\w\W]+?)\s*\[\/\1]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(?<tag>[^\\]]+)]\\s*(?<content>[\\w\\W]+?)\\s*\\[\\\/\\1]', 'g')
const str = `[SLUG]ghana-cocoa-supply-shortfall-impacts-traders[/SLUG]
[TITLE]Sweet Trouble: Ghana's Cocoa Shortfall Leaves Traders in a Bitter Spot[/TITLE]
[EXCERPT]Ghana's cocoa bean delivery hiccup has traders facing a whopping \$1 billion loss. Here's what happened and why it matters for your morning mocha.[/EXCERPT]
[BODY]
<p>Hey there, chocolate lovers and market watchers! Grab your favorite cocoa-based snack because we've got some news that might make your wallet feel a little lighter (but hopefully not your candy bar).</p>
[/BODY]
[CATEGORIES]Finance,Commodities,Global Trade[/CATEGORIES]
[TAGS]cocoa,Ghana,commodities,trading,supplychain,chocolate[/TAGS]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}