#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^\|\|\s+([^\n|]+)\s+\|\|((?:(?!^\|\|).)+)"
Local $sString = "|| This is title ||" & @CRLF & _
"" & @CRLF & _
"- item1" & @CRLF & _
"- item2" & @CRLF & _
"- item3" & @CRLF & _
"" & @CRLF & _
"|| This is another title ||"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")