using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\|\|\s+([^\n|]+)\s+\|\|((?:(?!^\|\|).)+)";
string input = @"|| This is title ||
- item1
- item2
- item3
|| This is another title ||";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}