re = /^\|\|\s+([^\n|]+)\s+\|\|((?:(?!^\|\|).)+)/m
str = '|| This is title ||
- item1
- item2
- item3
|| This is another title ||'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end