import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\|\\|\\s+([^\\n|]+)\\s+\\|\\|((?:(?!^\\|\\|).)+)";
final String string = "|| This is title ||\n\n"
+ "- item1\n"
+ "- item2\n"
+ "- item3\n\n"
+ "|| This is another title ||";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}