using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[-+]?([1-8]?\d(\.\d+)?|90?|90(\.0+)?){1}\s{1}[-+]?(180{1}|180(\.0+){1}|((1[0-7]\d{1})|([1-9]?\d){1})(\.\d+)?)\s?([-+]?(\d+(\.0+)?))?$";
string input = @"90 125 23";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}