import Foundation
let pattern = #"^[-+]?([1-8]?\d(\.\d+)?|90?|90(\.0+)?){1}\s{1}[-+]?(180{1}|180(\.0+){1}|((1[0-7]\d{1})|([1-9]?\d){1})(\.\d+)?)\s?([-+]?(\d+(\.0+)?))?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"90 125 23"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)