package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[?&]BkRef=([^&]*)`)
var str = `URL /information/feedback?RECIPIENT_ID=fb8eab5f4738ad75e5093ee0f57ce1eb,fb8eab5f4738ad75e5093ee0f57ce1eb&BkRef=20927158&pid=email&sid=nfprog.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}