import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[?&]BkRef=([^&]*)";
final String string = "URL /information/feedback?RECIPIENT_ID=fb8eab5f4738ad75e5093ee0f57ce1eb,fb8eab5f4738ad75e5093ee0f57ce1eb&BkRef=20927158&pid=email&sid=nfprog.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}