const regex = new RegExp('[?&]BkRef=([^&]*)', 'gm')
const str = `URL /information/feedback?RECIPIENT_ID=fb8eab5f4738ad75e5093ee0f57ce1eb,fb8eab5f4738ad75e5093ee0f57ce1eb&BkRef=20927158&pid=email&sid=nfprog.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}