use strict;
my $str = 'URL /information/feedback?RECIPIENT_ID=fb8eab5f4738ad75e5093ee0f57ce1eb,fb8eab5f4738ad75e5093ee0f57ce1eb&BkRef=20927158&pid=email&sid=nfprog.';
my $regex = qr`[?&]BkRef=([^&]*)`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}