using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0*[1-9]+)(0*[1-9]+)(0*[1-9]+)";
string input = @"0400000006340000000000965871
0700000007850000000000336487
0100000003360000000000444444";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}