import re
regex = re.compile(r"(0*[1-9]+)(0*[1-9]+)(0*[1-9]+)", flags=re.MULTILINE)
test_str = ("0400000006340000000000965871\n"
"0700000007850000000000336487\n"
"0100000003360000000000444444")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")