re = /(0*[1-9]+)(0*[1-9]+)(0*[1-9]+)/m
str = '0400000006340000000000965871
0700000007850000000000336487
0100000003360000000000444444'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end