// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(0*[1-9]+)(0*[1-9]+)(0*[1-9]+)").unwrap();
let string = "0400000006340000000000965871
0700000007850000000000336487
0100000003360000000000444444";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}