import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)(?'uc'(?=\\S*?[A-Z])))\n"
+ "(?(DEFINE)(?'lc'(?=\\S*?[a-z])))\n"
+ "(?(DEFINE)(?'num'(?=\\S*?[0-9])))\n"
+ "(?(DEFINE)(?'pun'(?=\\S*?[][()\\{\\}~!@$%^&*_+=\\\\:;\"'<>,.?\\/-])))\n"
+ "(password\n"
+ " |(\n"
+ " (?P>lc)(?P>num)(?P>pun)\n"
+ " |(?P>uc)(?P>num)(?P>pun)\n"
+ " |(?P>uc)(?P>lc)(?P>pun)\n"
+ " |(?P>uc)(?P>lc)(?P>num)\n"
+ " )\\S+ # change the \"+\" to \"{4,}\" to require a min-length\n"
+ ")";
final String string = "Should match:\n"
+ "password\n"
+ "a1.\n"
+ "Aa1\n"
+ "Aa.\n"
+ "Aa1.\n"
+ "Aabc123\n\n"
+ "Should not match:\n"
+ "abc123\n"
+ "AABB\n"
+ "A111\n"
+ "BBBbbb\n"
+ "192.168.1.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}