import re
regex = re.compile(r"""
(?(DEFINE)(?'uc'(?=\S*?[A-Z])))
(?(DEFINE)(?'lc'(?=\S*?[a-z])))
(?(DEFINE)(?'num'(?=\S*?[0-9])))
(?(DEFINE)(?'pun'(?=\S*?[][(){}~!@$%^&*_+=\\:;"'<>,.?\/-])))
(password
|(
(?P>lc)(?P>num)(?P>pun)
|(?P>uc)(?P>num)(?P>pun)
|(?P>uc)(?P>lc)(?P>pun)
|(?P>uc)(?P>lc)(?P>num)
)\S+ # change the "+" to "{4,}" to require a min-length
)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("Should match:\n"
"password\n"
"a1.\n"
"Aa1\n"
"Aa.\n"
"Aa1.\n"
"Aabc123\n\n"
"Should not match:\n"
"abc123\n"
"AABB\n"
"A111\n"
"BBBbbb\n"
"192.168.1.0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")