$re = '/(?(DEFINE)(?\'uc\'(?=\S*?[A-Z])))
(?(DEFINE)(?\'lc\'(?=\S*?[a-z])))
(?(DEFINE)(?\'num\'(?=\S*?[0-9])))
(?(DEFINE)(?\'pun\'(?=\S*?[][(){}~!@$%^&*_+=\\\\:;"\'<>,.?\/-])))
(password
|(
(?P>lc)(?P>num)(?P>pun)
|(?P>uc)(?P>num)(?P>pun)
|(?P>uc)(?P>lc)(?P>pun)
|(?P>uc)(?P>lc)(?P>num)
)\S+ # change the "+" to "{4,}" to require a min-length
)/mx';
$str = 'Should match:
password
a1.
Aa1
Aa.
Aa1.
Aabc123
Should not match:
abc123
AABB
A111
BBBbbb
192.168.1.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);