const regex = /(?(DEFINE)(?'uc'(?=\S*?[A-Z])))
(?(DEFINE)(?'lc'(?=\S*?[a-z])))
(?(DEFINE)(?'num'(?=\S*?[0-9])))
(?(DEFINE)(?'pun'(?=\S*?[][(){}~!@$%^&*_+=\\:;"'<>,.?\/-])))
(password
|(
(?P>lc)(?P>num)(?P>pun)
|(?P>uc)(?P>num)(?P>pun)
|(?P>uc)(?P>lc)(?P>pun)
|(?P>uc)(?P>lc)(?P>num)
)\S+ # change the "+" to "{4,}" to require a min-length
)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)(?\'uc\'(?=\\S*?[A-Z])))
(?(DEFINE)(?\'lc\'(?=\\S*?[a-z])))
(?(DEFINE)(?\'num\'(?=\\S*?[0-9])))
(?(DEFINE)(?\'pun\'(?=\\S*?[][(){}~!@$%^&*_+=\\\\:;"\'<>,.?\\\/-])))
(password
|(
(?P>lc)(?P>num)(?P>pun)
|(?P>uc)(?P>num)(?P>pun)
|(?P>uc)(?P>lc)(?P>pun)
|(?P>uc)(?P>lc)(?P>num)
)\\S+ # change the "+" to "{4,}" to require a min-length
)', 'gm')
const str = `Should match:
password
a1.
Aa1
Aa.
Aa1.
Aabc123
Should not match:
abc123
AABB
A111
BBBbbb
192.168.1.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}