using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @".*file:\W+(?<Trip>[\d-]+)_.*";
        string input = @"1                   <PNR>JDU8T3</PNR>      in file:      1003-4347-316_201801220319.xml";
        
        foreach (Match m in Regex.Matches(input, pattern))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}