package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*file:\W+(?<Trip>[\d-]+)_.*`)
var str = `1 <PNR>JDU8T3</PNR> in file: 1003-4347-316_201801220319.xml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}