const regex = /.*file:\W+(?<Trip>[\d-]+)_.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*file:\\W+(?<Trip>[\\d-]+)_.*', 'g')
const str = `1 <PNR>JDU8T3</PNR> in file: 1003-4347-316_201801220319.xml`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}