re = /.*file:\W+(?<Trip>[\d-]+)_.*/
str = '1 <PNR>JDU8T3</PNR> in file: 1003-4347-316_201801220319.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end