using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"vs_name\"":\""\w-(?<fqdn>.+)-\d+";
string input = @"""vs_name"":""v-juniper-uat.opco.sony-443"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}