$re = '/vs_name\":\"\w-(?<fqdn>.+)-\d+/m';
$str = '"vs_name":"v-juniper-uat.opco.sony-443",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);