package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)vs_name\":\"\w-(?<fqdn>.+)-\d+`)
var str = `"vs_name":"v-juniper-uat.opco.sony-443",`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}