re = /vs_name\":\"\w-(?<fqdn>.+)-\d+/m
str = '"vs_name":"v-juniper-uat.opco.sony-443",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end