using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"page\s[\d]?[\s\d\-of]+";
string input = @"Page 1 of 35Page 1-35Page 35
page 35 6663 24 page 34 opage o f 2";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}