// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)page\s[\d]?[\s\d\-of]+").unwrap();
let string = "Page 1 of 35Page 1-35Page 35
page 35 6663 24 page 34 opage o f 2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}