$re = '/page\s[\d]?[\s\d\-of]+/i';
$str = 'Page 1 of 35Page 1-35Page 35
page 35 6663 24 page 34 opage o f 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);