re = /page\s[\d]?[\s\d\-of]+/i
str = 'Page 1 of 35Page 1-35Page 35
page 35 6663 24 page 34 opage o f 2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end