const regex = /([a-zA-Z]{1})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]{1})', 'gm')
const str = `SONG
Another test Songtitle
SongTitle
So.la.la
What, if a comma or 123 or ??? would be in the name?
Special characters like # or ! or % or anything else?
`;
const subst = `$1.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);