import re
regex = re.compile(r"([a-zA-Z]{1})", flags=re.MULTILINE)
test_str = ("SONG\n"
"Another test Songtitle\n"
"SongTitle\n"
"So.la.la\n"
"What, if a comma or 123 or ??? would be in the name?\n"
"Special characters like # or ! or % or anything else?\n")
subst = "$1."
result = regex.sub(subst, test_str)
if result:
print(result)