use strict;
my $str = 'SONG
Another test Songtitle
SongTitle
So.la.la
What, if a comma or 123 or ??? would be in the name?
Special characters like # or ! or % or anything else?
';
my $regex = qr/([a-zA-Z]{1})/mp;
my $subst = '$1.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";