using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\.)\w+$";
string input = @"C:\Users\KlausP\Pictures\Screenpresso\201.8-01-24_13h40_38.png
C:\Users\KlausP\Pictures.png\Screenpresso\201.8-01-24_13h40_38.png
C:\Users\KlausP\.png
.\hallo
.\.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}