$re = '/(?<=\.)\w+$/m';
$str = 'C:\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png
C:\\Users\\KlausP\\Pictures.png\\Screenpresso\\201.8-01-24_13h40_38.png
C:\\Users\\KlausP\\.png
.\\hallo
.\\.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);