re = /(?<=\.)\w+$/m
str = 'C:\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png
C:\\Users\\KlausP\\Pictures.png\\Screenpresso\\201.8-01-24_13h40_38.png
C:\\Users\\KlausP\\.png
.\\hallo
.\\.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end