const regex = new RegExp('(?<=\\.)\\w+$', 'gm')
const str = `C:\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png
C:\\Users\\KlausP\\Pictures.png\\Screenpresso\\201.8-01-24_13h40_38.png
C:\\Users\\KlausP\\.png
.\\hallo
.\\.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}