#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+\d{1,3}|\d{1,3})?\s?(\(\d{2}\)|\d{2})?\d{4,5}-\d{4}"
Local $sString = "- (11)98756-1212" & @CRLF & _
"- 98765-4321" & @CRLF & _
"-+55 (11)94362-3708" & @CRLF & _
"- 97333-3723" & @CRLF & _
"- 98733-4344" & @CRLF & _
"- (11)97283-3849" & @CRLF & _
"1196377-3243"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")