use strict;
my $str = '- (11)98756-1212
- 98765-4321
-+55 (11)94362-3708
- 97333-3723
- 98733-4344
- (11)97283-3849
1196377-3243';
my $regex = qr/(\+\d{1,3}|\d{1,3})?\s?(\(\d{2}\)|\d{2})?\d{4,5}-\d{4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}