import re
regex = re.compile(r"(\+\d{1,3}|\d{1,3})?\s?(\(\d{2}\)|\d{2})?\d{4,5}-\d{4}", flags=re.MULTILINE)
test_str = ("- (11)98756-1212\n"
"- 98765-4321\n"
"-+55 (11)94362-3708\n"
"- 97333-3723\n"
"- 98733-4344\n"
"- (11)97283-3849\n"
"1196377-3243")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")