re = /(\+\d{1,3}|\d{1,3})?\s?(\(\d{2}\)|\d{2})?\d{4,5}-\d{4}/m
str = '- (11)98756-1212
- 98765-4321
-+55 (11)94362-3708
- 97333-3723
- 98733-4344
- (11)97283-3849
1196377-3243'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end