import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\{,])(\\s+)?(\\w+)(\\s+)?:";
final String string = "[{ endTime:\"2019-06-05T17:15:00.000+10:00\", startTime:\"2019-06-05T17:00:00.000+10:00\"}]\n"
+ "[{endTime:\"2019-06-05T17:15:00.000+10:00\",startTime:\"2019-06-05T17:00:00.000+10:00\"}]";
final String subst = "$1\"$3\":";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}