use strict;
my $str = '[{ endTime:"2019-06-05T17:15:00.000+10:00", startTime:"2019-06-05T17:00:00.000+10:00"}]
[{endTime:"2019-06-05T17:15:00.000+10:00",startTime:"2019-06-05T17:00:00.000+10:00"}]';
my $regex = qr/([{,])(\s+)?(\w+)(\s+)?:/mip;
my $subst = '$1"$3":';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";