// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)([{,])(\s+)?(\w+)(\s+)?:").unwrap();
let string = "[{ endTime:\"2019-06-05T17:15:00.000+10:00\", startTime:\"2019-06-05T17:00:00.000+10:00\"}]
[{endTime:\"2019-06-05T17:15:00.000+10:00\",startTime:\"2019-06-05T17:00:00.000+10:00\"}]";
let substitution = "$1\"$3\":";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}