re = /([{,])(\s+)?(\w+)(\s+)?:/mi
str = '[{ endTime:"2019-06-05T17:15:00.000+10:00", startTime:"2019-06-05T17:00:00.000+10:00"}]
[{endTime:"2019-06-05T17:15:00.000+10:00",startTime:"2019-06-05T17:00:00.000+10:00"}]'
subst = '$1"$3":'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result